FAQ  •  Search  •  Profile  •  Log in to check your private messages  •  Log in
 Linux support for new version? View next topic
View previous topic
Post new topicReply to topic
Author Message
Favrenation
Kai Beginner
Kai Beginner


Joined: 22 Dec 2010
Posts: 7

PostPosted: Wed Jun 29, 2011 7:30 pm Reply with quoteBack to top

I heard you guys are working on an OSX port and if that is made a linux port shouldn't be really hard but is it in the works or at least though about? This is one of the main reasons why I dual-boot.
View user's profileSend private message
karmic
Kai Regular
Kai Regular


Joined: 02 Jan 2006
Posts: 145

PostPosted: Thu Jun 30, 2011 10:43 am Reply with quoteBack to top

It seems they are alike in Unix system but quite different in nature.

_________________
XLinkKai on Linux ( http://www37.atwiki.jp/linux_kai/ )
View user's profileSend private message
Favrenation
Kai Beginner
Kai Beginner


Joined: 22 Dec 2010
Posts: 7

PostPosted: Thu Jun 30, 2011 3:45 pm Reply with quoteBack to top

Well yeah but they use similar libraries like mono for instance. It is easier to make a mac program work on linux than it is to make it work on windows at least in general.
View user's profileSend private message
karmic
Kai Regular
Kai Regular


Joined: 02 Jan 2006
Posts: 145

PostPosted: Thu Jun 30, 2011 5:02 pm Reply with quoteBack to top

It seems they are using quite different libraries.

_________________
XLinkKai on Linux ( http://www37.atwiki.jp/linux_kai/ )
View user's profileSend private message
Favrenation
Kai Beginner
Kai Beginner


Joined: 22 Dec 2010
Posts: 7

PostPosted: Thu Jun 30, 2011 8:47 pm Reply with quoteBack to top

how so?
View user's profileSend private message
karmic
Kai Regular
Kai Regular


Joined: 02 Jan 2006
Posts: 145

PostPosted: Sat Jul 02, 2011 10:49 pm Reply with quoteBack to top

Have you ever seen kaiengine for MacOSX?
Although we still don't know about new version, version 7.4.18 depends on the following libraries.

Code:
$ otool -L /Applications/kaiengine.app/Contents/MacOS/kaiengine
/Applications/kaiengine.app/Contents/MacOS/kaiengine (architecture ppc):
    /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
    /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 368.28.0)
    /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0)
    /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 11.0.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.3.6)
    /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime (compatibility version 1.0.0, current version 6.0.0)
    /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit (compatibility version 1.0.0, current version 1.0.0)
    /usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)
    /usr/lib/libiconv.2.dylib (compatibility version 5.0.0, current version 5.0.0)
    /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
    /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 18.0.0)
    /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 227.0.0)
    /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 824.42.0)
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 22.0.0)
    /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 567.29.0)
/Applications/kaiengine.app/Contents/MacOS/kaiengine (architecture i386):
    /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0, current version 275.0.0)
    /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 368.28.0)
    /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 128.0.0)
    /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 11.0.0)
    /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.3.6)
    /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime (compatibility version 1.0.0, current version 6.0.0)
    /System/Library/Frameworks/OpenGL.framework/Versions/A/OpenGL (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/AGL.framework/Versions/A/AGL (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/WebKit.framework/Versions/A/WebKit (compatibility version 1.0.0, current version 1.0.0)
    /usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.3)
    /usr/lib/libiconv.2.dylib (compatibility version 5.0.0, current version 5.0.0)
    /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.4.0)
    /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)
    /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices (compatibility version 1.0.0, current version 18.0.0)
    /usr/lib/libobjc.A.dylib (compatibility version 1.0.0, current version 227.0.0)
    /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 824.42.0)
    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/ApplicationServices (compatibility version 1.0.0, current version 22.0.0)
    /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 567.29.0)


Now that you mention it, we already know some issues in new version for Windows.
I wish it's the most immediate priority of Team XLink to fix it.

_________________
XLinkKai on Linux ( http://www37.atwiki.jp/linux_kai/ )
View user's profileSend private message
Favrenation
Kai Beginner
Kai Beginner


Joined: 22 Dec 2010
Posts: 7

PostPosted: Mon Jul 04, 2011 12:27 am Reply with quoteBack to top

Most of those libraries work on Linux. And yes they are lots of problems that can be fixed on the windows version.
View user's profileSend private message
Display posts from previous:      
Post new topicReply to topic


 Jump to:   



View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group :: Theme by Daz :: All times are GMT