I see that a lot of people are having trouble with Xlink Kai & Mac OS X .

If you are on Snow Leopard & you want to use Xlink Kai , then use this version : http://www.teamxlink.co.uk/binary/kaiEngine-7.4.18-osx-universal.pkg.zip

If you have Mac OS X Tiger , then use this version : Mac OSX 10.x Kaid Commander Bundle (Universal)

You can download that version here : http://www.teamxlink.co.uk/?go=download

Follow this Youtube video on how to get Xlink working with OS X Tiger : http://www.youtube.com/watch?v=_ECpj0aMcTA

I hope this helps .