FAQ  •  Search  •  Profile  •  Log in to check your private messages  •  Log in
 How to get XLink Kai working on Ubuntu 10.04 64bit View next topic
View previous topic
Post new topicThis topic is locked: you cannot edit posts or make replies.
Author Message
GrisuTheDragon
Kai Beginner
Kai Beginner


Joined: 09 Oct 2010
Posts: 2

PostPosted: Sun Oct 10, 2010 2:24 am Reply with quoteBack to top

Here's a small How-To for everyone who runs into the same trouble as I when trying to start kaiengine on Ubuntu 10.04 64bit.

When trying to run kaiengine I got the following error message:
"kaiengine: error while loading shared libraries: libwx_gtk2u_richtext-2.8.so.0"
Installing libwxgtk2.8-0 with "sudo apt-get install libwxgtk2.8-0" doesn't help, because it installs the 64bit libraries, but we need the 32bit libraries for kaiengine.

The easiest way to install 32bit libraries on a 64bit system is getlibs.
I installed libwxgtk2.8-0 with "getlibs -l libwxgtk2.8-0", but kaiengine gave me the next error:
"kaiengine: error while loading shared libraries: libwx_baseu_xml-2.8.so.0"
After solving this dependency by installing libwxbase2.8-0 with "getlibs -l libwxbase2.8-0", kaiengine started up nice and clean.

So in summary what you need to do is:
  1. Download and install getlibs: http://ubuntuforums.org/showthread.php?t=474790
  2. Install the 32bit versions of libwxgtk2.8-0 and libwxbase2.8-0 with: "getlibs -l libwxgtk2.8-0 libwxbase2.8-0"
  3. Change to the kaiengine directory and run kaiengine with "sudo ./kaiengine"

That's basically all there is to it, well at least it was for me. If you get an error message about Firefox not responding, close the message and open http://localhost:34522/ with Firefox to get to the XLink Kai web interface.

If you get more error messages about missing libraries you can use the Ubuntu Packages Search to find out the package name and install it with getlibs as shown above.

This How-To should work with all Debian based 64bit linux distributions and the basic method of installing the 32bit libraries should also work with other 64bit linux distributions, but I only tested it with Ubuntu 10.04.

Hope this helps someone.

Best regards
GrisuTheDragon


@Mods and Admins: Perhaps you can add this post to the XLink Kai Ubuntu (32 bit) Tutorial.
View user's profileSend private message
Critt
Kai Spammer
Kai Spammer


Joined: 09 Jul 2010
Posts: 1436

PostPosted: Sun Oct 10, 2010 11:13 am Reply with quoteBack to top

Nice Very Happy

_________________
-=-◙Image◙-=-
View user's profileSend private message
GrisuTheDragon
Kai Beginner
Kai Beginner


Joined: 09 Oct 2010
Posts: 2

PostPosted: Thu Oct 14, 2010 10:25 am Reply with quoteBack to top

Thanks CriTT and thanks to the team for the sticky. Smile
View user's profileSend private message
SgtLegend
TX Server Nerd
TX Server Nerd


Joined: 27 Nov 2007
Posts: 5257
Location: Melbourne, AU

PostPosted: Thu Oct 14, 2010 10:27 am Reply with quoteBack to top

Your welcome, ill lock this to keep it clean Razz
View user's profileSend private message
Display posts from previous:      
Post new topicThis topic is locked: you cannot edit posts or make replies.


 Jump to:   



View next topic
View previous topic
You can post new topics in this forum
You can reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group :: Theme by Daz :: All times are GMT