FAQ  •  Search  •  Profile  •  Log in to check your private messages  •  Log in
 Xlink won't work | Can't see any Games View next topic
View previous topic
Post new topicReply to topic
Author Message
Kai Beginner
Kai Beginner

Joined: 31 Mar 2019
Posts: 1

PostPosted: Sun Mar 31, 2019 10:13 pm Reply with quoteBack to top

Is your network reachable? Yes
Are you using a router? Yes
Did you set a static IP on the PC running Kai? No
Did you forward port 30000 to the static IP? Yes. My modem/router assigns portforwarding to my MAC adress, therefore I don't need to set a static IP and it will automatically forward to my adress, even if it changes due to a new DHCP lease.
Did you click the globe after forwarding to see if your network goes reachable? Yes
What console are you using? Xbox Classic
Is your console being detected? Yes
Brief description of your network setup: Modem/router connected to a switch, xbox and PC are both connected to the switch
Model numbers of the router, and modem? You probably don't know them since they're pretty much region bound: AVM FritzBox 7590
Do you use a software firewall? What brand? Have you made any changes to it? Windows Firewall, Xlink UI and Engine are both allowed to pass, inbound and outbound
Operating System? Win 10 64bit
Problem description?
Everything looks fine from configuration wise, but my mate and I (he has pretty much the exact same setup as I do except for a FritzBox 7490, earlier model) just can't find any games. We tried Time Splitters 3 - Future Perfect on Xbox aswell as Halo 2. We googled like crazy and did find some answers just like enable NAT/PAT, use port forwarding (Port 30000) to the PC on TCP and UDP (which we both did) and much more, but nothing really works. Our consoles are being found immediatly, this works fine. But still - We can't find games.

# XLink Kai Engine Configuration
#  Version 7.4.33


# Use automatic login

# Use Web User Interface instead of GUI program

# Automatically launch Kai user interface

# User interface program name

# Web UI Password

# Automatically open chat

# Automatically assign IP addresses to PS2 Consoles

# Automatically assign IP addresses to PS3 Consoles

# Automatically assign IP addresses to PS4 Consoles

# Automatically assign IP addresses to Gamecube Consoles

# Automatically assign IP addresses to XBox One Consoles

# Automatically assign IP addresses to Switch Consoles

# Automatically assign IP addresses to XBox Consoles for homebrew

# Automatically assign IP addresses to XBox 360 Consoles for homebrew

# Enable XBox homebrew

# Enable XBox 360 homebrew

# Disable sleep mode

# Enable PSP Mode (Automatic SSID detection)

# Enable Switch Wireless Mode

# MBCS code page for asian character sets

# Language

# Enable port address translation

# Set UDP port for peer-to-peer connections (0=random)

# Set TCP port for Web UI connections (connect with[portnumber]/)
#  Default is 34522 - this does not need to be changed in most cases.  You DO NOT need to forward this port in your router.

# Autodetect Proxy Server

# Proxy server IP address

# Proxy server port

# Network adapter (!=autodetect)

# Automatically shut down engine after x minutes (0=never)

# Automatically shut down engine when UI closes

# Accept connections from user interfaces on other computers

My Metrics screen output looks like this:

Orbital Name   TX Ottawa DEV
Reachable   Yes
Public IP
Public Port   30000
Engine Version   7.4.33
PSSDK/WinPcap   Windows/Winpcap
Signed By   Team XLink
Ethernet Adapter   Realtek Ethernet Controller
Locked   1
Up Engine Traffic   0
Down Engine Traffic   0
Chat Traffic   0
Down Chat Traffic   0
Up Orb Traffic   0
Down Orb Traffic   0
PSSDK/WinPcap (again?)   Winpcap
Mac Cache Entrie   0
Broadcast Traffic Inbound   0
Broadcast Traffic Outbound   0
Unicast Traffic Inbound   0
Unicast Traffic Outbound   0
Wireless SSID   n/a

Inbound and ountbound traffic sometimes show some bytes flowing on both machines. I can't select PSSDK instead of Winpcap, the Ethernet adaptor was chosen automaticly.

Any suggestions? Crying or Very sad

Thanks in advance!
View user's profileSend private message
Team XLink Moderator
Team XLink Moderator

Joined: 23 Mar 2012
Posts: 235

PostPosted: Thu Apr 04, 2019 3:07 pm Reply with quoteBack to top

Have you tried connecting to other players? It might only be one of you having an issue.

If you can see broadcast traffic outbound while searching, that's a good sign.

Can you establish a ping to the majority of users?

^Click Me^
View user's profileSend private message
Display posts from previous:      
Post new topicReply to topic

 Jump to:   

View next topic
View previous topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Powered by phpBB © 2001, 2002 phpBB Group :: Theme by Daz :: All times are GMT